HOME > Download > Integrated Development Environment > system
Download : Integrated Development Environment

Curl CDE System Requirements

The CDE 8.0.4001 is supported and tested on the following versions of Eclipse:

  • 3.7.2, 3.8.2
  • 4.2.2, 4.3
    CDE doesn't support running on a 64bit Eclipse, even if you are using a 64bit OS, please use 32bit java VM, and 32bit eclipse installation.
JVM(Java Virtual Machine)
- Sun/Oracle's JDK 1.6+ recommended

The system configuraiton requirements for the CDE are the same as the requirements for a typical Eclipse environment:
  • Intel Pentium III 800 MHz processor
  • 1 GB RAM (2GB or more recommended)
  • a minimum display resolution of 1024 x 768

Curl IDE System Requirements

Version 8.0.1004

Windows®


Supported Operating Systems
  • Windows® XP SP3
  • Windows® Vista sp2
  • Windows® 7 SP1
  • Windows® 7 SP1 64bit
  • Windows® 8
  • Windows® 8 64bit

Notes:
Curl IDE only supports running on 64bit windows through WOW64

Supported Browsers
  • Microsoft® Internet Explorer (IE) 7.0, 8.0 and 9.0
  • Microsoft® Internet Explorer (IE) 8.0 64bit and 9.0 64bit on Windows® 7 SP1 64bit.
  • Microsoft® Internet Explorer (IE) 10.0 for the desktop on€ Windows® 8 (IE10 with windows® 8 UI is not supported)
  • Firefox 22.0
  • Firefox 17.0.7 ESR
CPU
    PentiumR II 400 MHz (PentiumR III or higher recommended)
Memory
    128 MB RAM (256 MB recommended)
Hard Disk
    254 MB hard disk space

Linux


Supported Operating Systems
  • Ubuntu 12.04 LTS
  • CentOS 6.4
Supported Browsers
  • Firefox 22.0, Firefox 17.0.7 ESR
CPU
    PentiumR II 400 MHz (PentiumR III or higher recommended
Memory
    128 MB RAM (256 MB recommended)
Hard Disk
    172 MB (total RTE and IDE)
Supported Window Managers
    Ubuntu 12.04 LTS:
  • GNOME 3.4
  • KDE 4.8
  • UNITY 5
    CentOS 6.4:
  • GNOME 2.28
  • KDE 4